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1 May 2025

Requirements:
Windows 8, 10, 11
macOS 10.11 or later

Overview:

Black Cat ALE Vacuum Cleaner processes SDR 1/Q recording files, looking for and
decoding ALE signals found in the passband. This makes it possible to quickly and
easily find many of the ALE transmissions in your SDR recordings, without having to
manually find and decode them one by one. This means it only works with recording
files, not with “live” signals.

SDR 1/Q recording files to analyze. Presently the following formats are supported:
+ Elad

« Ggrx

« KiwiSDR

* Perseus

* RFSpace (Spectravue and SdrDx)

« SDR Radio -WARNING — THIS FILE FORMAT CHANGES OFTEN, MAY NOT WORK
« SDR# / Baseband Recorder

* SDR++

« Studio 1

« SDRuno (Studio1, format 2)

Please note: SDR 1/Q recording file formats are not well documented. I've done my best
to figure out the formats, but it involves a lot of guesswork. There’s a good chance of
some edge cases that cause problems. Or SDR app authors that routinely change the
format, breaking things. | won’t name any names © If some files don’t appear to work,
contact me, and maybe we can figure things out. Likewise, if there’s a format not
presently supported, | can look into adding it. I'll need sample files of course, and ideally
some scraps of information from the program author as to the format.

IMPORTANT: PLEASE DO NOT CHANGE I/Q RECORDING FILENAMES! The
filename format is one of the characteristics this program uses to distinguish between
formats (which SDR program wrote the file). If you change the filename, the file will
likely be misidentified and not properly processed.

Some Caveats About ALE Decoding:



Please remember that the program is searching through the entire 1/Q recording file
looking for ALE transmissions. It may not find all of them. It may also “find”
transmissions that don’t really exist, either due to noise or other signals being mis-
identified. The emphasis of the program is weak signal detection, over rejecting any and
all false signals. It’s up to you, the user, to weed out the bad from the good.

ALE transmissions are broken up into words, each of which contains up to three
characters of a callsign, as well as the preamble type (TO, TIS, TWAS, etc.). For
callsigns of three (or fewer) characters, the entire callsign can be transmitted in a single
word.

Callsigns longer than three characters must be broken up into two or more words, the
additional characters are transmitted via a series of DATA/REP words. Up to a total of
five words can be sent, allowing for callsigns up to 15 characters in length.

ALE words are sent several times, this redundancy helps, but does not eliminate, the
chance of words being lost. It’s entirely possible that no words representing a certain
portion of a callsign will be received, especially when signals are weak. This can result
in a portion of the callsign being missed. For example, if the callsign of a station is
ABCDEF, it’s possible that no words containing the DEF portion of the callsign will be
received, resulting in the callsign ABC being displayed. It’s critical that the user carefully
examines the callsigns of received messages, noting possible cases of this occurring.
Once you know the general format of callsigns in a particular ALE network, this
becomes fairly easy.

ALE words contain error detection/correction bits, this allows rejection in most cases of
invalid words. But there is always the statistical chance that random noise will happen to
produce an ALE word that passes these checks, especially in the case of very sensitive
decoding software that is looking for weak signals down in the noise. It’s a tradeoff.

There is an option in the settings that specifies the minimum number of valid ALE words
that must be received for a message to be displayed. As this value is increased, the
number of random decodes displayed is drastically reduced.



How to use Black Cat ALE Vacuum Cleaner:

First, launch the program.

Next, you need to specify which frequencies will be searched. You can control whether
LSB and/or USB frequencies will be searched, as well as which frequency offsets, 0.0

kHz and/or 0.5 kHz.

This capability covers virtually all of the active ALE frequencies, with the exception of
the US State Department networks which use 0.6 kHz channels.

Next the general settings need to be, well, set. Select Settings from the Edit menu.
Here are what my settings look like:

| NON ) Settings
Data Offsets
Number of decoding threads: 10 u (change after restart)
Demodulation: Closest <)
Data feed delay: 0
Frequency resolution: Low E (change after restart)
Auto Log Set File /Users/cps/rbdev/ALEVaccumCleaner/vacuum logs.txt
I/Q File Format: Auto u
Message Format: Space delimiter u

Neaten formatting No Callsign Info E

File watch delay: 5 E sec Delete 1/Q file after processing
End of Tx Dead Time: 4 E sec Minimum Rx Words: 4 E
Only Display Parsed Messages Print Duplicates

The number of decoding threads controls how many CPU threads will be used to
process the recording files. More threads mean faster processing — to a point. Once
you’ve reached the number of CPU cores on your system you will not see further
benefit. More threads also mean your system will be taxed more by the program, run
warmer, spin your cooling fans, etc. To help mitigate this you can add a data feed delay,
which will pause between batches of recording data.



Demodulation controls how the program looks for ALE tones. | suggest using Range,
with Smoothing set to 1.

Set the frequency resolution to Medium, based on testing higher values are of little
benefit, lower values impair decoding quality. But as always, you can experiment to see
what works best for you.

Auto Log can be used to specify a text file that will be automatically opened when the
program is launched, for storing decoded messages.

I/Q File Format can be used to tell the program which format they are in, if Auto does
not reliably detect it.

Message format and Neaten formatting control how messages are displayed.

File watch delay and Delete I/Q file after processing are used when automatically
looking for new files to process, see the section in this documentation related to that.

End of Tx Dead time controls how long after the last ALE word is received the
transmission will be assumed to be finished, and displayed.

Minimum Rx Words specifies how many ALE words must be received for a message to
be displayed. Because the decoder is so sensitive, random noise will sometimes get
mis-interpreted as an ALE word. Setting this to a value larger than 1 will help reduce or
eliminate false decodes.

Only Display Parsed Messages should usually be checked, so you only see completely
formatted ALE messages. Left unchecked, you will see each ALE word, which is only
useful in certain special cases.

Print Duplicates can be checked if you want to see repeated transmissions of the same
exact ALE message.

UTC Offset: If the 1/Q recording files aren’t in the UTC time zone, this value will be
added to the timestamps in the file. For example, if your files are in the EST timezone
(UTC-5) then putting 5 in this field will add 5 hours to the timestamp, making them UTC.

Reject incomplete messages: If checked, messages with missing address fields, such
as ABC___GHI will not be displayed.

Bandwidth: Normally the bandwidth value in 1/Q recording files, if present, will be used.
If none is present, then the bandwidth will be set to 80% of the sample rate. You can



enter a value in this field to override either of these. For example, setting to 100 will set
the bandwidth to 100% of the sample rate.

Display Decoding File Info: When checked status messages will be added to the text
decode area when processing of an 1/Q file starts, finishes, and the file is deleted. When
not checked, these messages will not be displayed, reducing clutter. Some other
messages indicated error conditions however will always be displayed.

Close this window after making any changes, so the changes take effect. Note that
some changes only take effect after a restart of the program.

In the Edit menu, there are options to set the background color of the window as well as
the text font, size, and color, and whether or not to auto scroll the window with new text.



Printing additional information about callsigns:

Black Cat ALE Vacuum Cleaner can use one or more text files to provide additional
information about callsigns.

You need to create a directory to store these callsigns. One suggestion is to create one
called "ale_callsigns" in the Documents directory for your user account.

From the Callsigns menu, pick Set Callsigns Directory... and then select the directory
you created.

You can put one or more PLAIN TEXT files into this directory, the program will look for
them when it is opened.

The first line of each text file should contain this text on the first line: CALLSIGN_FILE

These files should be a tab delimited list of callsigns, along with two or more descriptive
fields (one for the organization and one for more details), with another tab between
each. So:

callsign [ tab] organization [tab] details [return]

Any deviation from this format will cause it to not be parsed.

When a callsign matches an entry in the list, the organization and/or details will be
displayed after it, in curly braces { }. This functionality is controlled in the settings.

If there are two or more callsigns with the same name, then information will not be
printed for that callsign, instead "Ambiguous - multiple entries" will be printed.

You can select which file to use from the Callsigns menu in the program. You can select
"Load All" to load all of the callsign files.

As each file is loaded, a line of text will be displaying indicating the number of callsigns
in the file, the name of the file, and the total number of unique callsigns so far loaded
into the program. This is a useful diagnostic to help check that there are no errors in
your callsign files.

An example callsign file:
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302013 AFAD Adiyaman - Province TUR
302018 —AFAD Adiyaman-Province TUR
303013 —~AFAD Afyonkarahisar -Province »TUR
303018 —~AFAD Afyonkarahisar - -Province »TUR
303313 —AFAD Afyonkarahisar -Province »TUR
304013 —AFAD Agri-Province TUR

304018 —AFAD Agri-Province TUR

305013 —~AFAD Amasya-Province :TUR

306013 AFAD Ankara —TUR

306018 —AFAD Ankara —TUR

306023 —AFAD Ankara —TUR
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147 343013 —-AFAD Kitahya- Province TUR
148 343018 —~AFAD Kitahya- Province TUR
1449 344013 AFAD Malatva Province TIIR
Figure 1: Such a look-up table makes identification and logging easy.




Feeding in data:

Now we’re reading to start processing some SDR recording files, looking for ALE
transmissions. But first you may want to select Start Logging from the File menu, so
your decodes are saved to a text file. Select Stop Logging when done, or you can just
quit the program.

Select Open 1/Q Files from the File menu, and select one or more SDR recording files.
Hopefully files that contain ALE transmissions. Black Cat ALE Vacuum Cleaner will
then start processing the files. How long will this take? It depends on the size of the file,
the bandwidth, how many frequencies you’ve selected to decode, and how fast your
computer is. The title of the main window will update showing the progress, and
decodes will be displayed as soon as they are found.

It is strongly recommended to start with SDR recording files with a reasonable
bandwidth/sample rate. Don’t immediately start with a 80 MHz sample rate file that
covers the entire 0-30 MHz HF spectrum, as tempting as that may be. It probably won’t
work. Start with a 200 kHz file to get your feet wet and learn how to use the program.
Then slowly increase the bandwidth, to see what works on your system. | routinely use
1 MHz bandwidth files, and have used files at several MHz. The program is still in
development, and I’'m working on determining exactly what the limits are. You’re
certainly free to try extremely wide recording files, but don’t complain if/when they don’t
work ©

You can select Show 1/Q Files Awaiting Processing from the File menu to get another
window with a list of files queued for processing, and a rough (very rough) estimate of
how much longer it will take to finish.

If you want to abort processing of all files, both the currently processing file and those
queued, select Abort Processing from the File menu. There’s also options to pause and
resume processing. While processing is paused, you can select additional files to
process, then resume processing afterwards.

Select Clear Decodes from the Edit menu to clear out the text in the Window.

Feed Decodes in the File menu and Clear Parsers in the Edit menu are for my testing
purposes.

Automatically decoding files:

Black Cat ALE Vacuum Cleaner can look for new 1/Q recording files and automatically
process, and optionally delete, them.



Go to the File menu and select Set Directory To Monitor For New 1/Q Files, then choose
the directory where your SDR software stores the files.

Then select Monitor 1/Q File Directory from the File menu. Black Cat ALE Vacuum
Cleaner will monitor this directory, looking for new files. When it finds one, it will wait
until it is no longer being written to or opened by your SDR program. It will then open
the file and start processing it.

If you have checked Delete 1/Q file after processing in Setup it will attempt to delete the
file when done.

Also, in Setup you can vary the File watch delay setting. This is the number of seconds
the file size must not change for it to be considered finished. A good starting point is 5
seconds.

It’s surprisingly tricky to determine when another program is no longer writing to a file,
especially if the file is on another computer over a network, so another check is to see if
the file can be opened. If so, it is assumed that it’s finished and safe to being processing
it. But please note this is not foolproof, and it may appear it is no longer opened by your
SDR program when it actually still is.

Workflow suggestions:

Monitoring the same portion of the HF spectrum for an extended time period (over many
days) will likely result in dozens, perhaps hundreds of callsigns being decoded.

The vast majority of these will be soundings, with a lesser number of two-way (ABC
calling XYZ) transmissions. It’s the latter that can most easily reveal networks, by
observing which stations are in contact with each other. Soundings can also be useful,
by comparing which frequencies are shared by the same groups of callsigns.

Spreadsheets, databases, and other tools can help organize the abundance of
callsigns, making relationships between stations more obvious.



Software License Agreement

This is a legal agreement between you and Black Cat Systems. covering your use of
Black Cat ALE Vacuum Cleaner (the "Software"). Be sure to read the following
agreement before using the Software. BY USING THE SOFTWARE (REGARDLESS IF
YOU HAVE REGISTERED THE SOFTWARE OR NOT), YOU ARE AGREEING TO BE
BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO THE
TERMS OF THIS AGREEMENT, DO NOT USE THE SOFTWARE AND DESTROY ALL
COPIES IN YOUR POSSESSION.

The Software is owned by Black Cat Systems and is protected by United States
copyright laws and international treaty provisions. Therefore, you must treat the
Software like any other copyrighted material (e.g., a book or musical recording). Paying
the license fee allows you the right to use one copy of the Software on a single
computer. You may not network the Software or otherwise use it or make it available for
use on more than one computer at the same time. You may not rent or lease the
Software, nor may you modify, adapt, translate, reverse engineer, decompile, or
disassemble the Software. If you violate any part of this agreement, your right to use
this Software terminates automatically and you must then destroy all copies of the
Software in your possession.

The Software and its related documentation are provided "AS I1S" and without warranty
of any kind and Black Cat Systems expressly disclaims all other warranties, expressed
or implied, including, but not limited to, the implied warranties of merchantability and
fitness for a particular purpose. Under no circumstances shall Black Cat Systems be
liable for any incidental, special, or consequential damages that result from the use or
inability to use the Software or related documentation, even if Black Cat Systems has
been advised of the possibility of such damages. In no event shall Black Cat Systems'
liability exceed the license fee paid, if any.

This Agreement shall be governed by the laws of the State of Maryland. If for any
reason a court of competent jurisdiction finds any provision of the Agreement, or portion
thereof, to be unenforceable, that provision of the Agreement shall be enforced to the
maximum extent permissible so as to affect the intent of the parties, and the remainder
of this Agreement shall continue in full force and effect.

The Software and documentation is provided with RESTRICTED RIGHTS. Use,
duplication, or disclosure by the Government is subject to restrictions as set forth in
subdivision (b)(3)(ii) of the Rights in Technical Data and Computer Software clause as



252.227-7013. Manufacturer is Black Cat Systems., 4708 Trail Court, Westminster, MD
21158, United States of America.

The name "Black Cat Systems", and “Black Cat ALE Vacuum Cleaner" are trademarks
of Black Cat Systems. Black Cat ALE is ©2021-2025 by Black Cat Systems. All rights
reserved worldwide.



