
Carrier Sleuth 
Version 2.4.0 – 5 September 2023 
 
Program information and download: 
http://blackcatsystems.com/software/medium_wave_carrier_display_app
.html 
 
NOTE: Bug reports are welcome, please include step by step 
instructions for reproducing them. 
 
SDRs are extremely useful for the MW DXer, the entire MW band can 
be recorded overnight, and then examined later for stations of interest. 
But it can be overwhelming to go through hours of SDR I/Q recording 
files. The usual approach is to play the recording file back through the 
SDR software, looking for potentially interesting signals. This process 
takes hours, and you still miss things.  
 
Carrier Sleuth helps you find stations of interest. It generates very high-
resolution waterfalls, from I/Q recording files made by several SDR 
(Software Defined Radio) programs.  These waterfalls are centered on 
each of the MW carrier frequencies and are narrow in bandwidth, often 
around 100 Hz wide. These waterfalls can be used to observe the 
multitude of MW (Medium Wave) stations on a single channel at the 
same time, even when only one station can be clearly heard. Or even 
when no station can be heard, such as with the 9 kHz channels from 
Europe and Asia. Carrier Sleuth does this by performing very long FFTs 
on the data, up to a 16 million-point FFT. 
 
Carrier Sleuth will generate these waterfalls for all MW channels 
contained within the I/Q recording file bandwidth. For example a 200 
kHz wide I/Q recording file, centered on 1600 kHz, will produce 
waterfalls for 1500, 1510, 1520… 1700 kHz. Optionally you can also 
produce waterfalls for the 9 kHz spaced channels.   
 



After this processing is done, the results can be saved, and then quickly 
reloaded (without the need to process the raw data again) and you can 
step through the channels looking for signals of interest. 
 
 
  



Below is a waterfall centered on 1710 kHz. Several carriers are visible, 
for example the one at 1710.027 kHz is the Springfield Armory TIS 
station in Massachusetts. Around 1709.994 kHz you can see two carriers 
which I believe are pirate stations (they went on and off the air a few 
times just before 2300 UTC), and there is another pirate that signed on at 
2350 UTC and settled on 1710.001 kHz.  It went off the air jusst after 
0300 UTC. You can see the drift in carrier frequency when stations go 
on the air, most likely due to thermal effects, heating of the transmitter’s 
oscillator, etc. 
 
What’s useful is that the waterfall helps you pinpoint exactly when a 
station signed on/off or faded in/out. You can then play back that portion 
of the I/Q recording file in your SDR software to listen to it.  
 

 



Next is a waterfall centered on 1600 kHz. A few things of interest: 
 
The station around 1599.959 kHz has a sawtooth pattern to its carrier 
frequency. Some stations have patterns like this that can be used as 
“fingerprints” to help identify them, in addition to their exact carrier 
frequency. 
 
Around 2230, a stations carrier frequency shifted from 1599.993 to 
1599.999 over the course of about half an hour, probably due to 
changing to night power levels. This time be used to help narrow down 
what station it may have been. 
 
A station on 1600.007 went off the air at 2130, presumably a daytimer 
shutting down for the day. Again, this information can be used to help 
ID it. 
 

 
  



Finally, a waterfall from 1730 kHz. This was a pirate from Greece, 
received here in the USA. The waterfall showed me when it signed on 
(again you can see the slight drift) and off. I was able to go to that 
portion of my I/Q recording files, play them back, and listen to the 
audio. Reception in this case was strong enough to ID several of the 
songs they played.  
 

 
 
 
  



General Usage 
 
Currently, I/Q recording files from the following programs are 
supported: 
 
•  ELAD SW2 
•  Gqrx 
•  Linrad 
•  Perseus 
•  SdrDx 
•  SDR-Radio 
•  SDRuno 
•  SpectraVue  
•  Studio1 
•  KiwiSDR I/Q files 
 
I do not have all of these SDR programs, so I rely on recording files 
made by others, and therefore cannot guarantee that all work correctly. 
 
When Carrier Sleuth is launched, you will see the main window, which 
will be blank other than some controls. You first need to process your 
I/Q recording files to see the waterfalls. It is assumed at this point you 
have some, if not, you need to make a few with your SDR software. To 
get started, I suggest making a few files at a 100 to 250 kHz bandwidth, 
each of which is 1 or 1.9 GB in length. Previously, files had to be kept 
less than 2 GB in length, or they would not be correctly processed. 
Carrier Sleuth is being updated to support larger files and this does work 
in most cases, but should still be considered experimental at this point, 
so you need to experiment with your particular setup. 
 
Select Open I/Q Files(s)... from the File menu in Carrier Sleuth. 
 
Next you need to specify the output file, this is where Carrier Sleuth will 
save the resulting waterfalls. Click the Set Output File button, navigate 
to where you want to store the file, and enter in the name of the file. If 



Auto Set is checked, the output filename will default to the same name 
as the first I/Q file, except with .fft as the extension. NOTE: if you have 
an output (FFT) file currently open in Carrier Sleuth, do NOT save to 
that same file, or it will crash.  Also, and this is especially true for the 
Windows version which is presently a 32 bit app: It is recommended to 
quit and re-launch Carrier Sleuth when processing another batch of I/Q 
files, as otherwise it may run out of memory. 
 
Next you need to specify the characteristics of the waterfalls: 
 
First, the FFT Length. Longer FFT lengths produce higher resolution 
waterfalls, but they are shorter in length (in pixels), and take longer to 
generate. You can start with a 2M length to get a feel for things, then 
experiment with different lengths. 
 
Speedup can be used to increase the temporal resolution of the created 
waterfall. It may best be explained by example: 
 
With the default value of 1, the I/Q data is processed normally. For 
example, if the FFT length is 1M points, 1M (one million) samples are 
read from the I/Q file in chunks, and fed through a 1M point FFT. 
 
With a speedup value of 2, I/Q data is read in chunks of 512K (half a 
million) samples. The first two chunks, let's call them A and B, are 
processed normally as a 1M point FFT. Then a third 512K chunk is read, 
C. Chunks B and C are next processed as another 1M point FFT, and so 
on. The resulting waterfall is now twice as long. This can be useful to 
increase the apparent vertical resolution. Of course this comes at the 
expense of some smearing of the FFT output data. Higher speedup 
factors can also be selected, in powers of 2.  
 
In addition, values of ½, ¼, and ⅛  can also be selected. In these cases, 
speedup is actually “speed down” and can be used to reduce the length, 
and size, of the generated waterfalls.  
 



Next the Frequency Width. I like to use 100 Hz most of the time, or 200 
Hz if there could be some carriers much further away from the nominal 
frequency. Or 50 Hz or even less if they are all close in. Again, you can 
experiment. 
 
Then the Display Width, which is the width of the resulting waterfall in 
pixels. The default 1024 pixels is a good compromise. 
 
If your SDR sample rate is not exact (in general, if it is not locked to a 
GPS or other reference... it isn't) you can enter a ppm error value, and 
Carrier Sleuth will compensate. 
 
Then pick which MW channels you want to look at. 9 kHz channels are 
used outside of North and South America, 10 kHz channels inside.  
 
If you would like to use your own set of frequencies/channels, perhaps 
because you want to examine something other than the MW band, check 
the Custom Channels box. You will see a new window where you can 
enter in frequencies, in kHz, separated by spaces or commas. Such as 
11900 11925 11940 11975  Then click the Set button, and this window 
will close. The app will use these frequencies. You can copy and paste 
onto this window, so you can prepare a list of frequencies in a text editor 
if you wish, and just paste them in, so you do not have to type them by 
hand.  
 
One important note – the resulting output file must be less than 2GB in 
length. Carrier Sleuth will estimate the length of the output file and 
display this at the bottom of the window. If the length is larger than (or 
very close to) 2 GB, then adjust parameters to reduce the length. 
Increasing the FFT length for example will reduce the length.  
 
Now click the Add File(s) button, and select your SDR recording files.  
Carrier Sleuth will list them in the left side of the window, sorted by 
time. It will also display the frequency range covered by the files. Note 
that it only looks at the first file to determine this, it assumes all of the 



files have the same bandwidth / sample rate. If they do not, strange 
things could happen. Carrier Sleuth will generate waterfalls for every 
MW channel that falls within this range. 
 
If you want to remove the files from the list click Clear Files. And then 
add some new files. 
 
Unfortunately, I/Q recording file formats are not very well documented. 
Well, that's an understatement, they're generally not documented at all. 
And some SDR program authors have a habit of changing the format, 
breaking things. In addition to making it difficult for Carrier Sleuth to 
correctly parse information such as the sample rate, center frequency, 
and so on, it also can cause the I/Q data bytes to become offset.  
 
As a bandaid for the latter, there is a field in the window called "Data 
offset". Normally this is left at zero. But it can be changed to correct for 
offsets in the data stream.  What value should be entered? You'll need to 
experiment, I can't tell you. For a 16 bit recording file, the possible 
values are 0, 1, 2, and 3. For a 24 bit file, 0 through 5, and for a 32 bit 
file 0 through 7.  
 
How will you know if you need to adjust this value? Generally, if the 
output waterfalls don't look right. Again, I can't tell you, you need to 
experiment. Usually you will find two values that appear to work, but 
one will result in frequencies flipped around the center frequency, due to 
the I and Q values being swapped. So that's the value you don't want to 
use :) 
 
When processing Linrad files, there is the capability to handle two 
channel files, and select which channel will be processed. 
 
Finally click the Process button. If all goes well, this window will close, 
and you will return to the main window. The progress indictors at the of 
the window will appear, which show how far along the program is in 
processing the files. The first is the progress within the current file, the 



second is the progress through all of the files. It can take a long time to 
process files, depending on how many, their size, the speed of your 
computer, FFT length, and so on. So, you may want to start with just one 
or two files to get the hang of things. 
 
When it is done, the waterfall for the first channel will be displayed. It 
may look ugly, so adjust the Max dB and Min dB sliders as necessary.  
There is the Auto Set dB Sliders item in the Edit menu which should get 
you close enough to then fine tune things. 
 
You should see one or more vertical lines which are the carriers of MW 
stations on that channel (unless of course you picked a channel without 
any that were received on your recording). You can scroll up and down, 
and change the window size. There are time markers drawn every hour 
on the waterfall. You can also move your cursor on the window and the 
time and frequency will be displayed at the top of the window. 
 
The Channels menu will be populated with a list of every channel a 
waterfall was generated for. You can select any channel of interested, 
and use cmd-D and cmd-U (control-D and control-U on Windows) to 
step up or down through the channels. There are also the < and > buttons 
to step through channels. Holding down shift when clicking will step 
through 10 channels at a time, for quickly advancing through them. 
 
Save Waterfall Image... from the File menu will save the image as a 
PNG file. 
 
Copy Waterfall Image from the Edit menu will copy the image to your 
clipboard (pasteboard) so you can paste it into another application.  
 
View Notes from the Edit menu brings up a window where you can 
enter in some free form text notes for your own use. These are stored 
within the file. This can be useful to record information such as QTH, 
equipment used, etc. 
 



If you want to re-load this set of waterfalls, or another previously 
generated file, use Open FFT File from the File menu. It will load them 
without having to re-generate them from the I/Q recording files, which is 
a huge time saver. 
Rotate Waterfall in the Edit menu will toggle between the normal 
waterfall orientation, and a rotated waterfall with time in the x-axis. 
 
You can right click on a waterfall, and select several options from the 
resulting popup menu: 
 
Save as CSV will save a text file with comma separated signal values for 
the frequency you right clicked on. 
 
Graph as Signal and Graph as Noise will open a new window and allow 
you to graph one frequency as a signal and another as a background 
noise level. 
 
See further down in this documentation for details on how to use the 
select Add CSV Frequency option. 
 
 
 
Palette Files 
 
You can load a custom waterfall palette by Selecting Load Palette File 
from the File menu. Currently, palette files from SdrDx, SpectraVue, 
and WSJT-X/MixW/fldigi are supported. A palette file must conform 
rigorously to the defined format, any deviation will cause it to be 
rejected.  
 
Select Default Palette from the File menu to return to using Carrier 
Sleuth’s default palette.  
 
 
 



Show Help from the Help menu brings up this document, but you 
probably knew that already. 
 
 
 
  



Generate CSV File 
 
This tool will produce a CSV (comma separated value) text file showing 
the signal strengths of a user defined set of frequencies, after I/Q data 
has been processed into an FFT file. The resulting CSV file can be 
imported into a spreadsheet or other application, and graphed.  
 
The frequency width (in Hz) is specified, which is then converted to a 
range of FFT bins, depending on the I/Q sample rate and FFT length. 
 
For each specified frequency and set of temporal FFT values, the FFT 
bins are analyzed, and the largest value from any of the FFT bins is 
used. 
 
The input file is a plain text file, consisting of list of frequencies in kHz, 
one entry per line. For example: 
539.9994 
540.0062 
550.003 
550.0007 
650.019200 
680.0094 
680.0011 
... 
 
The generated file is in CSV format, for example (note this example will 
likely display as wrapped text): 
 
Timestamp,539.9994,540.0062,550.003,550.0007,650
.0192,680.0094,680.0011,1000.003,1010.002,1040.0
07,1060.001,1090.002,1099.995,1120.002,1130.001,
1140.01,1210.002,1219.998,1230.002,1230.017,1240
.001,1250.002,1279.997,1350.001,1380.006,1389.99
5,1600.004,1610,1689.994,1700.002,1709.995,1710.
008,1740.022,1750.015 



08/22/2020 12:12:17,-63.17188,-77.35938,-
71.22656,-69.96094,-26.14844,-42.15625,-
74.57812,-50.97656,-55.9375,-56.57812,-45.125,-
28.80469,-79.24219,-49.5625,-51.625,-68.625,-
44.22656,-53.85938,-50.19531,-49.21094,-
70.89844,-38.51562,-23.61719,-26.25781,-
58.72656,-48.57031,-46.88281,-76.42188,-
48.85156,-54.67188,-65.33594,-106.5703,-
105.4141,-123.2578 
08/22/2020 12:12:26,-63.42188,-77.40625,-
68.60938,-67.10938,-26.16406,-41.67969,-
78.10156,-53.59375,-56.98438,-69.41406,-
45.65625,-28.17188,-81.11719,-48.25,-49.94531,-
74.02344,-43.22656,-50.94531,-52.92969,-
49.76562,-62.73438,-39.21875,-23.63281,-
26.54688,-59.98438,-51.60938,-46.6875,-
77.32812,-64.05469,-54.78125,-63.6875,-
96.99219,-104.5703,-125.8672 
08/22/2020 12:12:36,-63.21875,-76.75781,-
66.79688,-65.46094,-26.0625,-41.4375,-81.57031,-
54.35156,-58.14062,-68.35156,-46.27344,-
30.16406,-90.85938,-48.44531,-47.57031,-
75.50781,-44.10156,-58.60156,-52.97656,-
54.32812,-54.26562,-39.46094,-23.60156,-
26.69531,-60.39844,-52.15625,-49.40625,-
79.16406,-62.77344,-53.10156,-65.01562,-
104.5234,-106.5156,-122.4688 
08/22/2020 12:12:45,-63.02344,-76.52344,-
65.5625,-64.1875,-26.09375,-41.5,-84.625,-
52.75,-54.17188,-59.82031,-46.09375,-31.19531,-
79.97656,-52.02344,-66.64062,-74.35156,-
43.21875,-52.80469,-51.27344,-55,-60.95312,-
39.92969,-23.59375,-26.85938,-66.63281,-
50.72656,-52.92188,-77.32812,-55.70312,-
52.35938,-68.21094,-99.74219,-107.5547,-125.4297 



08/22/2020 12:12:55,-62.92188,-77.01562,-
66.53125,-65.17188,-26.04688,-42.45312,-
81.21875,-54.04688,-52.36719,-60.94531,-
51.53906,-32.54688,-80,-47.92969,-52.85938,-
73.76562,-47.0625,-62.53906,-51.52344,-
56.02344,-60.54688,-38.9375,-23.60156,-
26.96094,-60.25781,-44.64062,-49.25,-78.79688,-
54.28125,-50.64844,-64.92969,-96.07031,-
109.7031,-125.5 
 
There is one header line, followed by data lines with signal strengths for 
each frequency from the input file.  Each line corresponds to a displayed 
row of pixels in the waterfall, the temporal spacing depends on the FFT 
length, speedup factor, and sample rate of the input I/Q file. 
 
The signal strengths are in dB. Conversion to dBm could be done by 
adding an offset, assuming you know the characteristics of your entire 
receiving setup. That is left as an exercise for the reader. 
 
If a specified frequency is not contained in the FFT file passband, a zero 
value will be written for the signal strength. 
 
It may also be useful to specify one or more frequencies containing no 
apparent signal as "noise" frequencies, to produce a baseline background 
noise level. 
 
One factor to consider is that many MW carriers drift over time. The 
frequency width needs to be selected to be large enough to accommodate 
this drift, while being narrow enough to reject other signals. There may 
be cases where due to excessive drift or interfering signals, it is difficult 
or impossible to accurately extract the carrier strength information for a 
given signal. 
 



Another factor is drift of the SDR itself. The use of high stability (GPS 
referenced, for example) frequency references for the SDR ADC clock is 
highly recommended.  
 
Typical use: 
 
Process I/Q files to produce an FFT file, or load an existing FFT file. 
 
Select Generate CSV File... from the File menu. 
 
Set the frequency width, in Hz. 
 
Click the "Select Frequency Input File" button to load the list of 
frequencies to analyze. 
 
Carrier Sleuth will then step through each frequency for analysis. While 
this happens, status information will be displayed in the Generate CSV 
File window, the displayed frequency in the main window will change 
as needed. 
 
When analysis is finished, you will be prompted to save the resulting 
CSV file.  
 
 
 
Generating a CSV frequency file: 
 
Right click in the waterfall on the first frequency for the file, select Add 
CSV Frequency. A new window will open, CSV Frequencies, with this 
frequency as the first in the list. Alternately, an existing text file can be 
opened by selecting Open CSV Frequencies from the File menu. 
 
Go back to the waterfall and select additional frequencies, they will also 
be added. 
 



The list can be sorted by selecting Sort CSV Frequency Window from 
the Edit menu. 
 
Entries in the list can be edited. 
 
Save the list by selecting Save CSV Frequencies from the File menu.  
 
 
 
  



Process Directly To CSV File 
 
This tool will directly produce a CSV (comma separated value) text file 
showing the signal strengths of a user defined set of frequencies from a 
set of I/Q recording files. 
 
Select “Process Direct To CSV...” from the File menu. 
 
Click the Add I/Q File(s) button to select the I/Q files to be processed. 
You can select multiple files at a time. Click Clear I/Q File(s) to remove 
all previously selected files and start over again.  
 
Select the desired FFT length. 
 
Correct for SDR ADC sample clock error, if desired. 
 
Data offset can be used to allow processing of some I/Q files that do not 
follow the correct format.  
 
Click Set Freq File and choose the input file, which is a plain text file, 
consisting of list of frequencies in kHz, one entry per line as with the 
previous Generate CSV File tool. 
 
Specify the frequency width. For each input frequency, this range will be 
analyzed, and the maximum dBm value written to the output file.  
 
Click Set Output File to set the CSV text file that will be written to. 
 
Click Process. The window will close and a new Processing I/Q Files 
window will open. There are two lists in this window, one the left one 
that shows all frequencies from the input file, as well as the frequency 
range that will be analyzed relative to the center frequency of the I/Q 
file, and one on the right which shows all of the I/Q files and the 
processing status of each file.  
 



Processing will automatically begin, and finish when the last file has 
been analyzed. The window can be closed after processing is finished, 
and the resulting CSV text file will then be ready for use. 
 
Clicking Cancel will close this window without processing. 
 
 
 



Preferences Window 
 
This window allows several vales to be set: 
 
Group separator character for CSV files. Usually this is a comma in the 
USA and Canada, and a semicolon in much of the rest of the world.  
 
Timestamp color: The color of the timestamp displayed over the 
waterfall. 
  



Version History: 
 
 
2.4.0b – 5 September 2023 
Added option to right click on spectrum to generate simple signal 
strength vs time graphs directly in the program for two frequencies (the 
signal of interest as well as a "background" noise plot for an empty 
frequency. 
Added support for Linrad I/Q files. 
Added support for KiwiDR I/Q files. 
Corrected bugs reading SDR Console files. 
 
2.2.0b11 – 8 September 2021 
Some user interface bug fixes. 
 
2.2.0b10 – 7 September 2021 
Can rotate the spectrum so time is in the x-axis. 
Added option to load palette files. 
 
2.2.0b7 – 1 March 2021 
Checked for duplicate custom carrier frequencies, which would cause a 
crash. 
 
2.2.0b6 – 25 February 2021 
Fixed a bug that could cause a crash if a recent file was deleted. 
 
2.2.0b5 – 15 February 2021 
More changes to the group separator characters for CSV files.  
Fixed a bug with recent files. 
 
2.2.0b4 – 14 February 2021 
Added Preferences window, to set the group separator character for CSV 
files, and the color of the timestamp displayed on the waterfall. 
Added small marker lines to the waterfall frequency axis. 



Relocated the frequency and time text for the cursor position to the left 
side of the window. 
Added recent files menu. 
Saves dB slider values between launches. 
Added warning if I/Q files already processed this launch. 
 
 
2.2.0b3 – 31 January 2021 
Holding down shift when clicking the < or > button steps through 10 
channels at a time. 
 
2.2.0b3 – 31 January 2021 
Fixed (hopefully) Speedup. 
Added Divide by 2,4, and 8 options to Speedup. 
Some user interface tweaks, improvements to decoding larger than 2GB 
files. 
 
2.2.0b2 – 29 January 2021 
Added checks for missing data to prevent a crash in those cases. 
 
2.2.0b1 – 28 January 2021 
I/Q files larger than 2GB now supported in many (but not all?) cases. 
Added support for GQRX files. 
Added support for SDRConsole RF64 files. 
Added popop menu to set timestamp period. 
Added auto setting of output file name. 
Fixed a few bugs, some that could cause a crash. 
 
2.1.0 – 25 January 2021 
Fixed some bugs with reading SDR# baseband recordings. 
Added Direct Generate CSV File window. 
Added estimated of the output file size. 
 
2.0.0 10 December 2020: 
Added generation of CSV files. 



Added generation of a CSV frequency file via contextual clicks on the 
waterfall. 
Added Auto Set dB Sliders. 
Changed timestamp date format for CSV files to YYYT-MM-DD 
HH:MM:SS. 
Added option to drop frequencies outside the passband when producing 
CSV files. 
Bug fixes. 
 
1.3.1 - 24 July 2020: 
Bug fix, the cursor information text label was obscured after processing 
I/Q files. 
 
1.3.0 - 23 May 2020: 
Hi-DPI support. 
 
1.2.0 - 25 December 2019: 
Added ppm correction. 
Added crosshair cursor. 
MW channels now go up to 1730 kHz. 
 
1.0.7 - 25 February 2018: 
Forced I/Q files that appear to be 32 bit to be 16 bit. 
 
1.0.6 - 22 February 2018: 
Updated the range minimum and maximum dB values for the waterfall 
color scaling. 
 
1.0.4 - 3 August 2017: 
Fixed a bug that could cause a crash when using a 32M point FFT. No, 
really, I did this time! I think. 
 
1.0.3 - 2 August 2017: 
Fixed a bug that could cause a crash when using a 32M point FFT. 
 



1.0.2 - 31 July 2017: 
Corrections for reading SpectraVue files. 
Now uses all of the data at the end of a recording file. 
 
1.0.1 - 30 July 2017: 
Added Custom Channels. 
 
1.0.0 - 29 July 2017: 
Initial Release. 
 
 
 
 
  



Software License Agreement  

This is a legal agreement between you and Black Cat Systems. covering 
your use of the Carrier Sleuth (the "Software"). Be sure to read the 
following agreement before using the Software. BY USING THE 
SOFTWARE (REGARDLESS IF YOU HAVE REGISTERED THE 
SOFTWARE OR NOT), YOU ARE AGREEING TO BE BOUND BY 
THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO 
THE TERMS OF THIS AGREEMENT, DO NOT USE THE 
SOFTWARE AND DESTROY ALL COPIES IN YOUR 
POSSESSION.  

The Software is owned by Black Cat Systems and is protected by United 
States copyright laws and international treaty provisions. Therefore, you 
must treat the Software like any other copyrighted material (e.g., a book 
or musical recording). Paying the license fee allows you the right to use 
one copy of the Software on a single computer. You may not network 
the Software or otherwise use it or make it available for use on more 
than one computer at the same time. You may not rent or lease the 
Software, nor may you modify, adapt, translate, reverse engineer, 
decompile, or disassemble the Software. If you violate any part of this 
agreement, your right to use this Software terminates automatically and 
you must then destroy all copies of the Software in your possession.  

The Software and its related documentation are provided "AS IS" and 
without warranty of any kind and Black Cat Systems expressly disclaims 
all other warranties, expressed or implied, including, but not limited to, 
the implied warranties of merchantability and fitness for a particular 
purpose. Under no circumstances shall Black Cat Systems be liable for 
any incidental, special, or consequential damages that result from the use 
or inability to use the Software or related documentation, even if Black 
Cat Systems has been advised of the possibility of such damages. In no 
event shall Black Cat Systems's liability exceed the license fee paid, if 
any.  



This Agreement shall be governed by the laws of the State of Maryland. 
If for any reason a court of competent jurisdiction finds any provision of 
the Agreement, or portion thereof, to be unenforceable, that provision of 
the Agreement shall be enforced to the maximum extent permissible so 
as to effect the intent of the parties, and the remainder of this Agreement 
shall continue in full force and effect.  

The Software and documentation is provided with RESTRICTED 
RIGHTS. Use, duplication, or disclosure by the Government is subject 
to restrictions as set forth in subdivision (b)(3)(ii) of the Rights in 
Technical Data and Computer Software clause as 252.227-7013. 
Manufacturer is Black Cat Systems., 4708 Trail Court, Westminster, 
MD 21158, United States of America.  

The name "Black Cat Systems" and "Carrier Sleuth" are trademarks of 
Black Cat Systems.  

 
Carrier Sleuth ©2017-2021 Black Cat Systems, All Rights Reserved. 
 


