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Black Cat NetFinder imports and analyzes text files consisting of pairs of callsigns from 
monitored radio communications traffic, helping you construct diagrams showing the 
participants of each network.  
 
A network is defined as the collection of callsigns which are in communication with each 
other, either directly (A communicates with B) or indirectly (A communicates with B, B 
with C, therefore A,B, and C are all in the same network).  
 
Black Cat NetFinder performs the laborious task of sifting through this data, determining 
which stations are in the same network.   
 
Some assumptions: 
 
A given callsign is only in one network. If you believe your logging data contains the 
same callsign used in multiple networks you will need to divide it into separate files and 
process each collection as its own project. 
 
 
Data files: 
 
Black Cat NetFinder currently imports logging data from several file formats: 
 
• Black Cat ALE 
• Black Cat GMDSS CSV Database output 
• KiwiSDR ALE logs 
• A plain text format for user created loggings 
 
The plain text files must adhere to the following format: 
 
The first line must be only this text: PLAIN TEXT FORMAT 
 
Subsequent lines are data, with one line per logging. Each line contains up to four 
fields, tab delimited, with the following fields: 
 
From Callsign 
To Callsign 



Frequency and mode 
Timestamp 
 
The first field is the FROM callsign, this field is mandatory. 
 
The second field is the TO callsign, it is optional (i.e. in the case of an ALE sounding). 
 
The third field (also optional) is the frequency in kHz, optionally with a single space 
character followed by the mode (a single word). 
 
The fourth field (also optional) is a timestamp, of the form YYYY-MM-DD HH:MM:SS 
 
 
 
Basics: 
 
Start Black Cat NetFinder, you'll have an empty project.  
 
The first step is to add one or more data files - see the previous section for information 
on which types of files are accepted. Choose Add Data... from the File menu and select 
one or more data files. 
 
These files will be read, parsed, and loaded into the project, if there are any errors 
reading the files, you'll be informed. Then the networks will be built from the callsign 
data, note that this can take some time, especially with a large amount of data. When 
finished, you'll see a new window with a summary of what happened. 
 
One or more networks will be created, each one will be given a name such as Network 
1, Network 2, etc. You can of course rename your networks, this is done from the list of 
networks. Select one of the networks, and click on it again until you're able to edit the 
text.  
 
The data itself is displayed in three lists. The first one displays any data that only 
contains logs with a "from" (sender) callsign, such as ALE soundings. Frequency and 
timestamp information is displayed, if present in the data file. As only one callsign is 
present, this information cannot be automatically used to build networks, but may be of 
use to you, such as to see which callsigns use which frequencies, etc. 
 
The second list displays any data that only contains logs with a “to” (recipient) callsign. 
Similar to the above list otherwise.  
 
The third and more useful list contains logs with both a "from" and "to" callsign, and are 
used to automatically build networks. Frequency and timestamp information is displayed 
as well, along with the network to which each message was assigned. 



 
A popup menu at the top of the window is populated with each of the created networks. 
This is used to select which network is drawn, as well as which is used to populate the 
various lists. You can also use Next Network and Previous Network from the Edit menu, 
as well as their shortcut keys, to advance through the networks without using the popup 
menu. 
 
Several other lists are created as well. Besides the aforementioned list of networks, 
these are: 
 
A list of all callsigns assigned to the current network, along with the number of 
messages sent to or from each callsign. 
 
A list of all frequencies used in the current network, along with the number of messages 
on each. 
 
A list of all callsigns in the current network, with the number of messages sent to it. 
 
A list of all callsigns in the current network, with the number of messages from it. 
 
A list of all callsigns in the current network, with the number of messages sent to and 
from it. 
 
A list of all callsigns in the project, with the assigned network. 
 
Selecting a different network from the popup menu will change the current network, re-
populating the lists as well as re-drawing it on the network diagram, which you can 
select using the Diagram tab, and which will be discussed next. 
 
Below is a very simple network: 
 

 
 
 



There are three callsigns in this network, with arrows connecting them, and providing 
some additional information: 
 
4FNAFA sent one message to EWD. 
EWD sent one message to 4TAAAR. 
4TAAAR sent two messages to EWD. 
 
You can click on a callsign, and move it around the diagram, the arrow(s) will follow it. 
 
When networks are created, their callsigns are randomly placed on the diagram. Since it 
can be time consuming and difficult to roughly sort out a bunch of callsigns, there is an 
Auto Arrange feature. Click the checkbox to turn it on, and then adjust the three sliders 
and watch the callsigns move around. The model used is similar to the physical model 
of springs and electrostatic repulsion. The first two sliders set what is equivalent to the 
spring length and constant, the third the repulsive force. You can adjust them while it is 
updating, and you can also manually move callsigns around. Uncheck the box when 
you’re satisfied with this rough layout, and want to manually fine tune things.  Be careful 
not to let callsigns escape the borders!  If you’re not happy with how the arrangement of 
callsigns is going, select Replot Callsigns from the Edit menu, and the callsigns for that 
network will be randomly placed again, so you can start over.  
 
Right click on a callsign, and you have several options: 
 
You can anchor it, so that Auto Arranging will not move it. Anchored callsigns 
automatically be highlighted with a thicker border drawn around them so they can be 
easily distinguished. You can also set a custom highlight color for a callsign, whether or 
not it is anchored.  
 
You can hide this callsign so it is not displayed, as well as hide or show neighbors. See 
the section further down on hiding/showing callsigns. 
 
You can edit the callsign, which will change the text of the callsign in all messages 
where it appears. This also gives you the option to delete all messages where it 
appears. Both of these are useful methods of dealing with corrupted callsigns in your 
data, although keep in mind the larger effects such editing or deletion can have, in 
altering network participants.  
 
Finally, you can copy the callsign text to the clipboard, for use with other programs, 
such as pasting into your web browser to conduct an internet search. 
 
 
 
Hiding/Showing Callsigns: 
 



It’s possible a project could have lots of callsigns in a network. It can become difficult or 
nearly impossible to clearly see them all, and the program operation can become very 
slow and sluggish due to the amount of information that needs to be drawn. The 
solution is to only display part of a network as you work on it. 
 
The easiest way to handle this is to select Hide All Callsigns In A Network from the Edit 
menu, which will do just what the name suggests. This can be repeated for as many 
networks as you wish.  Then for a network select one callsign from the list of callsigns in 
the network, right click on it, and select Show Callsign.  Now go back to the diagram 
and this callsign will be displayed. Next right-click on it, and select Show Neighbors, and 
those neighbors will be un-hidden and drawn. Position them as necessary, and repeat 
the process. 
 
 
Forcing two networks to combine: 
 
You may know that two networks are actually the same, and there just is not enough 
callsign data for the program to figure that out. You can force networks to combine 
using the “Callsign pairs to merge into a network” list. Right click on this list to add a 
new entry. Replace the Callsign 1 and Callsign 2 text with a callsign from each network. 
Then select Update Networks from the Edit menu, and the two networks will be 
combined into one.  
 
 
Deleting things: 
 
A message can be deleted by right clicking on it and selecting Delete. It’s also possible 
to edit the To or From callsign of a message. After doing this, you will probably want to 
select Update Networks from the Edit menu. 
 
Right clicking on a callsign in several of the lists will give you the option to delete it – this 
means removing all messages or soundings that reference this callsign, as well as 
removing it from its network. Note that this will rebuild all of the networks. 
 
 
Other things: 
 
Update Networks in the Edit menu can be used to fix any issues with networks, such as 
empty networks, and can be useful after editing information. 
 
Auto Center Network will adjust the scroll bars to center the current network as best as 
possible. Scroll bar values must be positive, so it may not be possible to perfectly center 
a network, but it will at least make it visible.  
 



Prune Small Networks will let you remove networks with fewer than a specified number 
of callsigns. It removes these networks, as well as any messages assigned to them. 
 
 
An Example: 
 
An example file is included with the download. Let’s go through the process of using it. 
 
Open Black Cat NetFinder, or if it is already open, select new Project from the File 
menu. 
 
Select Add Data… from the File menu and select the included example file.txt text file. 
You may also want to open this file in a text editor so you can see the contents, and 
compare to the earlier description of plain text files. 
 
The file will be processed, and a window will appear showing what was done, you can 
close this window after reading the contents: 
 

 
 
Two networks were created, the first with members MNO, DEF, ABC, and CAT and the second 
with members UVW and XYZ. 
 
The Data panel will be populated with the logging data: 
 



 
 
The messages are shown on the right, on the left are what are one way transmissions with just 
a FROM callsign, such as ALE soundings. Also shown are one way “TO” transmissions, typically 
with ALE this are corrupted transmissions where part of the message, the FROM portion, was 
missed. They may however still be useful.  
 
Next switch to the Lists panel which contains details information: 
 

 
 
On the left is information about each callsign: 
The number of messages to it 
The number of messages from it 
Another list with both the number of messages to and from each callsign 
A list of all callsigns in the project, with their assigned network 
 
On the right are three lists, the one on the left is the list of all networks in the project, on the 
right are two lists, one with data for each callsign in the currently selected network (Network 1) 
as well as the frequencies in this network.  
 



The popup menu in the upper right corner of the window can be used to change the current 
network, if we switch to Network 2 we see the following: 
 

 
 



Go back to Network 1 using the popup menu, then select the Diagram panel. It could be blank, 
because the actual size of the network diagram is larger than the window, and the window is 
not currently scrolled to display it. While you could scroll around to find it, there is an easier 
way: select Auto Center Network from the Edit menu. Now you should see something like this, 
although the relative locations of each callsign / network member will be different than shown 
below: 
 

 
 
We can see the four network members, although they are not optimally placed relative to each 
other, the initial arrangement is in fact random. You can select each callsign with the mouse 
and drag it around to better position it, but again, there is an easier way! Tick the Auto Arrange 
checkbox and the callsigns will begin moving around (see the earlier section of this 
documentation for details on how this feature is configured). Watch as they reposition 
themselves, hopefully in a more optimal arrangement.  
 
When you’re happy, untick the checkbox. If for some reason the layout does not converge on a 
practical arrangement, you can click the Replot button and they will again be randomly 
positioned, and you can start Auto Arrange again.  
 
I ended up with the following layout, after slightly increasing the Spring Length setting to pull 
them further apart: 
 



 
 
 
The arrows show the flow of messages between stations, with the number of messages also 
displayed. Hover the cursor over a callsign, and you are told how many neighbors it has, 
stations it sent messages to or received messages from. Hover over a line connecting two 
stations and the total number of messages is displayed along with the frequencies used. This 
information is displayed in the upper left corner of the window. 
 
At this point you may want to save your project, do this by selecting Save Project from the File 
menu, and give your project a file name. 
 
You can use the popup menu to select the next network, or use Next Network / Previous 
Network from the Edit menu, or their shortcut keys, to quickly cycle through networks. Again, 
the network may not be visible, select Auto Center Network from the Edit menu to do this 
automatically. If you have a lot of networks in a new project, Auto Center All Networks can be 
used to do this for all of them at the same time. 
 
Again, you may want to save your data, using Save Project, the same file name will be 
automatically used. Get in the habit of frequently saving just in case something goes wrong. 
 
 
Editing data: 
 
In addition to directly editing the callsign of an entry under the data tab, you can select multiple 
rows, and then Edit Sounding Callsign from the contextual (right click) menu to change all of 
these callsigns at once. This can be done for messages and Lone Tos as well. You can also select 
and delete multiple rows at a time. 
 
  



Matrix Tab: 
 
This tab shows a spreadsheet like display of all of the callsigns and frequencies for a network, 
with the number of messages either to or from each callsign, on a per frequency basis. This can 
be helpful to see patterns in frequency usage. 

  
 
 
  



Associated Tab: 
 
One disadvantage of relying solely on two way message traffic is the relative small number of 
such transmissions, vs one way transmissions, such as ALE soundings. The Associated tab uses 
all data: messages (either from or two a callsign), FROMs (soundings) and TOs from a user 
specified set of frequencies.  
 
On the extreme left is a list of all frequencies with traffic of some kind, along with the number 
of transmissions for each. Double clicking on an entry will place it in the box below this, which is 
the list of frequencies used for this analysis. You can add up to 100 frequencies to this list.  
 
After adding frequencies, select Update Networks from the Edit menu, and the main 
spreadsheet display will be populated with all callsigns found on any of these frequencies, as 
well as the number of transmissions for each.  
 

 
 
You can remove a frequency from the list of frequencies being analyzed by right clicking on it 
and selecting Delete. 
 
There could be other associated frequencies use by these callsigns. Select one callsign, and the 
frequencies used by it will appear in another small list under the main spreadsheet. Double click 
on a frequency to add it to the list of frequencies being analyzed, or click Add All to add all of 
them.  
 



You can also click the Add All button located under the lower right corner of the main 
spreadsheet. This will add all additional frequencies used by each callsign in the spreadsheet.  
 
Obviously, you need to be careful to not inadvertently add frequencies unrelated to your 
network of interest, although you can later delete them from the frequency list.  
 
A given callsign can be directly added, along with it’s frequencies, by entering it into the text 
box then clicking Add Callsign. 
 
In general, it is an iterative process of starting with one frequency or callsign, and then building 
up the list of frequencies in use.  Remember that Update Networks from the Edit menu must 
often be used to update the Spreadsheet display after adding frequencies, the updates are not 
automatic. 
 
Frequencies can be used by more than one network, which means you’ll see callsigns that are 
not really related to each other. One tool to help with this is the popup menu in the lower right 
corner of the window. It specifies the minimum number of frequencies a callsign must be 
observed on to appear in the spreadsheet. Even selecting just a value of 2 can help remove 
many spurious callsigns.  
 
  



Waterfall Tab: 
 
This displays all received messages, including FROMs and TOs, on a traditional “waterfall” plot, 
much like an SDR. Time is the Y axis, and frequency the X. Both can be scrolled. Popup menus 
are also available for each to set the scale. 
 
Hover the mouse cursor over a callsign/message and detailed information about the 
transmission will be displayed, including the timestamp as well as frequency and mode. 
 
You can right click on a callsign to set a highlight color for all appearances of it on the waterfall. 
You have possibly two highlighting options, allowing you to select either the FROM or TO 
callsign in cases where both are present. 
 
You can right click to hide (or then show) messages, Froms (soundings) or Tos.  
 
You can right click to open another window allowing you to specify which callsigns or 
frequencies should be displayed, to help reduce clutter. 
 
You can right click to select just one callsign to view, or one network of callsigns to view. 
 
You can also select which network of callsigns to view using the network popup menu in the 
upper right corner of the window. Note that this only has an affect when the waterfall is visible, 
if it is not visible then changing the popup has no effect. 
 
Note that a given transmission is only displayed in at most one highlight color, so if different 
colors are selected for each callsign of a message, only one will be used.  
   



Software License Agreement  

This is a legal agreement between you and Black Cat Systems. covering your use of Black Cat NetFinder 
(the "Software"). Be sure to read the following agreement before using the Software. BY USING THE 
SOFTWARE (REGARDLESS IF YOU HAVE REGISTERED THE SOFTWARE OR NOT), YOU ARE 
AGREEING TO BE BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO THE 
TERMS OF THIS AGREEMENT, DO NOT USE THE SOFTWARE AND DESTROY ALL COPIES IN 
YOUR POSSESSION.  

The Software is owned by Black Cat Systems and is protected by United States copyright laws and 
international treaty provisions. Therefore, you must treat the Software like any other copyrighted material 
(e.g., a book or musical recording). Paying the license fee allows you the right to use one copy of the 
Software on a single computer. You may not network the Software or otherwise use it or make it available 
for use on more than one computer at the same time. You may not rent or lease the Software, nor may 
you modify, adapt, translate, reverse engineer, decompile, or disassemble the Software. If you violate any 
part of this agreement, your right to use this Software terminates automatically and you must then destroy 
all copies of the Software in your possession.  

The Software and its related documentation are provided "AS IS" and without warranty of any kind and 
Black Cat Systems expressly disclaims all other warranties, expressed or implied, including, but not 
limited to, the implied warranties of merchantability and fitness for a particular purpose. Under no 
circumstances shall Black Cat Systems be liable for any incidental, special, or consequential damages 
that result from the use or inability to use the Software or related documentation, even if Black Cat 
Systems has been advised of the possibility of such damages. In no event shall Black Cat Systems' 
liability exceed the license fee paid, if any.  

This Agreement shall be governed by the laws of the State of Maryland. If for any reason a court of 
competent jurisdiction finds any provision of the Agreement, or portion thereof, to be unenforceable, that 
provision of the Agreement shall be enforced to the maximum extent permissible so as to affect the intent 
of the parties, and the remainder of this Agreement shall continue in full force and effect.  

The Software and documentation is provided with RESTRICTED RIGHTS. Use, duplication, or disclosure 
by the Government is subject to restrictions as set forth in subdivision (b)(3)(ii) of the Rights in Technical 
Data and Computer Software clause as 252.227-7013. Manufacturer is Black Cat Systems., 4708 Trail 
Court, Westminster, MD 21158, United States of America.  

The name "Black Cat Systems", and “Black Cat NetFinder" are trademarks of Black Cat Systems. Black Cat 
NetFinder is ©2021-2022 by Black Cat Systems 


